7plus

#1

Plus7 app on PS4 is absolutely dreadful. Every time an ad comes on it repeats multiple times then the show starts over. Impossible to watch anything.

1 Like
Seven Network - Programs and Schedules
#2

Yeah I had the same problem on ps3, Was hoping that the live streaming option would be on there but no go.

1 Like
#3

Wow the app for Plus7 is dreadful. Is there anyway to report this to channel 7?

#4

Not sure. PS4 is unusable. iOS app works fine on an iPad but Airplay isnt enabled in older models of Apple TV, so usesless for catchup.

#5

On my laptop it works really well. But the PS4 is shocking. Not unusable for me but virtually unusable. Hopefully they can sort Plus7 out a little. Surely a bit of money can be spent to fix these things up.

#6

Seven and Google sign online deal.
Seven West Media has signed a deal to have its content from shows such as My Kitchen Rules and Home and Away streamed on Google’s online video platform YouTube.

3 Likes
#7

There has been an update to the Telstra TV app.

There is now an ad at the beginning of each show (You cannot fast forward it ).

Live streaming has been added .

A different looking loading screen between the ad and the tv show.

Note- Live streaming is also on the 7Tennis App on this device.

#8

Perhaps they have upgraded the image quality on the Plus 7 app on the Telstra TV as on a fast connection the image no longer looks like an oil painting.

It’s not HD but it looks better than it used to be.

#9

Is there a way to watch my local Seven News bulletin on Plus7? I live in Adelaide but all I’m getting is the Gold Coast bulletin. I’ve put in my postcode in the live section, but this doesn’t change anything either. Thanks.

#10

I had the same problem with the perth one. I was in Melbourne last week and yeah needed to watch the Perth News when i was in bed… back at the hotel (3 hour time difference, so meant i wasn’t back at the hotel at 9pm , was out about when the 7 news perth was on air 6pm, Perth time).

#11

Shall PLUS7 do a watch First fast tracking shows from the US on there instead of waiting for Seven to air them?

1 Like
#12

Just saw this week’s episode of The Amazing Race on Plus7. I notice the video clip now has new smaller fonts for subtitles, however they are on a solid black background which blocks some of the on-screen graphics. The background should be semi transparent like before.

#13

I need some help. I am really not tech savvy.

So I have TCL Smart TV and click the red button to go to plus7. Everytime I watch a show on plus7 it works for about 30 seconds and then the volume cuts out. Is there a reason for this? Is it a plus7 thing or is it my tv? If it is my tv is there a way of fixing it. If it is a plus7 thing does anyone else have the same issues?

#14

I never have a problem with Plus 7 or iView.

#15

Working fine here. I am using it right now via Fetch TV

I’m going to guess its your TV, but there could be other factors. Have you tried using it on your computer (on the same internet connection) or another device? Does it have the same problem?

#16

I can use it fine on my computer and phone. Must be tv. Going to email the company as I have had a few issues.

#17

Following Verizon’s acquisition of Yahoo!, Seven will be launching a new fully-owned service to replace Plus7 within the next six months.

http://www.theaustralian.com.au/business/media/broadcast/seven-to-launch-new-catchup-tv-service-after-tahoo-tweak/news-story/8578218ee6ebccb39a74970d95c5418e

The new catch-up TV service will use content currently being broadcast on the Yahoo-hosted PLUS7 platform. It will be offered exclusively through the separate, fully-owned Seven platform within six months.

The Yahoo7 joint venture will continue as a news and video portal that makes revenue through digital advertising.


Edit: Note the misspelling of “Yahoo” in the URL and page title :sweat_smile:

#18

I’ve been trying for half an hour to watch the last 10 minutes of ep. 11 (second-last) of The Amazing Race (where my recording ended), and it’s been nothing but frustration. After one ad it starts the episode okay but if I advance to about 35 minutes it plays about 8 ads (well, I lost count), then goes black and freezes. The ads work but the show doesn’t. Tried many times in two browsers with the same result.

Addendum: Since jumping to a spot didn’t work I decided to let it play from the start, but it gets stuck after the big block of ads at the first break. They’ve left me no option but to get it by “other means”.

#19

Is it just me, or do Plus7 ads not roll if you are in another tab. Very annoying, but very clever. Also, when you take screenshots of a program, full screen or in window, the content is blacked out. Plus7 more like Sneaky7.

#20

Working on Chrome.

Screenshot_8