Android Box IPTV

I’ve been using MXQ Android box to watch the 7/9/10 streaming channels on my television, through an app called IPTV:

However in recent weeks this has stopped working all of a sudden, and no channel will load through the app. The same app is working fine on my phone. I have also tried using other IPTV apps like Lazy IPTV and Kodi on the box, and they don’t work either.

I have also reset the box back to factory settings.

Nothing I have tried has worked. Does anyone know what else I could do?

It just stopped working suddenly.


A few things come to mind, but first - is it connected via Wi-Fi? My Fetch TV box was, for some reason, totally hopeless over Wi-Fi even though it was within direct line of sight, 5 metres away from the router. I believe they used a pretty crappy wireless module in the Fetch box which is the cause of the issue, which I’d imagine a lot of these cheap set top boxes have.

Could you do a speed test from the box where it’s usually located in the house and compare it to a computer connected to the router via an Ethernet cable, or a device situated as close to the router as possible?

I say this because it’s pretty common for interference to crop up in wireless home networks and cause problems. Things like microwave, fluorescent lights and non-FCC compliant devices can really screw up a lot of stuff.

Yes it is connected via Wifi, and was working fine until a few weeks ago.

Sounds like the wifi hardware has possibly died

Do any other apps on the device that require an internet connection work?

I would also try connecting via Ethernet as mubd posted, to help determine what the cause of the problem could be

Yeah, try it over a wired connection first.

Yes, internet is working to other devices.

The wifi hardware in the Android box may have died, though. These things are built to a price, so you should try it out over a wired connection if that’s possible.